MidnightBSD Magus

math/R

Language for statistical computing and graphics

Flavor Version Run OSVersion Arch License Restricted Status
3.5.1 430 2.0 i386 gpl2 0 fail

Events

Machine Type Time Message
m2032 info 2020-10-28 15:11:18.342897 Test Started
m2032 fail 2020-10-28 15:15:42.155089 make install returned non-zero: 1
m2032 fail 2020-10-28 15:15:42.207609 Test complete.

Log

===>  Installing /magus/packages/All/R-3.5.1.mport
===>   R-3.5.1 depends on executable: gmake - found
===>   R-3.5.1 depends on file: /usr/local/bin/iconv - found
===>   R-3.5.1 depends on file: /usr/local/lib/libreadline.so.8 - found
===>   R-3.5.1 depends on package: ghostscript9-base>=9.06_11 - found
===>   R-3.5.1 depends on executable: gfortran7 - found
===>   R-3.5.1 depends on file: /usr/local/libdata/pkgconfig/ice.pc - found
===>   R-3.5.1 depends on file: /usr/local/libdata/pkgconfig/sm.pc - found
===>   R-3.5.1 depends on file: /usr/local/libdata/pkgconfig/x11.pc - found
===>   R-3.5.1 depends on file: /usr/local/libdata/pkgconfig/xext.pc - found
===>   R-3.5.1 depends on file: /usr/local/libdata/pkgconfig/xmu.pc - found
===>   R-3.5.1 depends on file: /usr/local/libdata/pkgconfig/xscrnsaver.pc - found
===>   R-3.5.1 depends on file: /usr/local/libdata/pkgconfig/xt.pc - found
===>   R-3.5.1 depends on shared library: libcurl.so - found (/usr/local/lib/libcurl.so)
===>   R-3.5.1 depends on shared library: libpcre.so - found (/usr/local/lib/libpcre.so)
===>   R-3.5.1 depends on shared library: libicui18n.so - found (/usr/local/lib/libicui18n.so)
===>   R-3.5.1 depends on shared library: libpng.so - found (/usr/local/lib/libpng.so)
===>   R-3.5.1 depends on shared library: libtiff.so - found (/usr/local/lib/libtiff.so)
===>   R-3.5.1 depends on shared library: libomp.so - found (/usr/lib/libomp.so)
===>   R-3.5.1 depends on shared library: libcairo.so - found (/usr/local/lib/libcairo.so)
===>   R-3.5.1 depends on shared library: libglib-2.0.so - found (/usr/local/lib/libglib-2.0.so)
===>   R-3.5.1 depends on shared library: libintl.so - found (/usr/local/lib/libintl.so)
===>   R-3.5.1 depends on shared library: libpango-1.0.so - found (/usr/local/lib/libpango-1.0.so)
===>   R-3.5.1 depends on shared library: libreadline.so.8 - found (/lib/libreadline.so.8)
===>   R-3.5.1 depends on shared library: libintl.so - found (/usr/local/lib/libintl.so)
===>   R-3.5.1 depends on shared library: libjpeg.so - found (/usr/local/lib/libjpeg.so)
===>   R-3.5.1 depends on shared library: libtk86.so - found (/usr/local/lib/libtk86.so)
===>   R-3.5.1 depends on shared library: libtcl86.so - found (/usr/local/lib/libtcl86.so)
mport.install: install failed: Error at /usr/src/lib/libmport/check_preconditions.c:(235): R depends on openmp, which is not installed.
Unable to install R-3.5.1: Error at /usr/src/lib/libmport/check_preconditions.c:(235): R depends on openmp, which is not installed.
*** Error code 1

Stop.
make: stopped in /usr/mports/math/R