MidnightBSD Magus

devel/apache-ant

Java- and XML-based build tool, conceptually similar to make

Flavor Version Run OSVersion Arch License Restricted Status
1.9.3 395 1.2 i386 apache2 0 fail

Events

Machine Type Time Message
m1232 info 2020-01-01 17:44:17.967122 Test Started
m1232 fail 2020-01-01 17:44:42.988029 make install returned non-zero: 1
m1232 fail 2020-01-01 17:44:43.037897 Test complete.

Log

===>  Installing /magus/packages/All/apache-ant-1.9.3.mport
===>   apache-ant-1.9.3 depends on executable: classpath - not found
===>  Installing /magus/packages/All/javavmwrapper-2.6.mport
Installing javavmwrapper-2.6
/usr/local/share/licenses/javavmwrapper-2.6/catalog.mk
/usr/local/share/licenses/javavmwrapper-2.6/LICENSE
/usr/local/share/licenses/javavmwrapper-2.6/other
/usr/local/bin/classpath
/usr/local/bin/javavm
/usr/local/bin/registervm
/usr/local/bin/unregistervm
/usr/local/bin/checkvms
/usr/local/bin/manvm
/usr/local/etc/javavm_opts.conf.dist

===>  Done.
===>   apache-ant-1.9.3 depends on executable: classpath - found
===>   Returning to build of apache-ant-1.9.3
===>   apache-ant-1.9.3 depends on file: /usr/local/openjdk7/bin/java - not found
Missing dependency package file: /magus/packages/All/openjdk-7.25.15_6.mport
make[1]: exec(exit) failed (No such file or directory)
*** Error code 1

Stop.
make[1]: stopped in /usr/mports/java/openjdk7
*** Error code 1

Stop.
make: stopped in /usr/mports/devel/apache-ant